Delayed Email Delivery
Incident Report for MemberSpace
Resolved
Our email provider has resolved their delivery issues and has worked through their backlog. Email delivery times are back to normal lighting fast speeds. ⚡️
Posted Feb 03, 2023 - 14:03 EST
Investigating
Our email provider is experiencing a service issue where outbound sending is delayed. Our emails are being delivered but delivery time is in minutes, not seconds as they normally are. Our email provider is investigating the issue. We will post updates as we learn more.
Posted Feb 03, 2023 - 13:13 EST
This incident affected: Worker Servers.