Major Outage - Infrastructure Provider is Down

Incident Report for MemberSpace

Resolved

Our infrastructure provider has resolved their network issues. Our systems are fully operational.
Posted Nov 18, 2025 - 10:22 EST

Investigating

A major 3rd party infrastructure provider is down and affecting all of our services. We are investigating.
Posted Nov 18, 2025 - 08:14 EST
This incident affected: Admin Backend, Website Javascript, and Our Website.