Intermittent Outages

Incident Report for MemberSpace

Resolved

Our service provider has implemented all fixes for the incident and is now operating normally.
Posted Jun 11, 2025 - 10:18 EDT

Investigating

A major downstream service provider of MemberSpace is currently experiencing intermittent outages. We are monitoring the situation and will provide an update as we learn more.
Posted Jun 10, 2025 - 10:09 EDT
This incident affected: Admin Backend and Worker Servers.